Техническая поддержка SpyBB

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Техническая поддержка SpyBB » Архив » Не работает скрипт Подфорумов!


Не работает скрипт Подфорумов!

Сообщений 1 страница 20 из 24

1

Скрипт для Подфорумов от (c) Usher работает прекрасно!А вот дополнение к ниму:  отображение наличия новых сообщений в подразделе на главной,что-то на работает! :( Создание подфорумов с помощью скриптов
Может кто объяснит подробней как и куда точно надо вставлять его?!Заранее благодарен!!!

Отредактировано BenDeen (15 Апр 2008 00:35:38)

0

2

BenDeen написал(а):

Может кто объяснит подробней как и куда точно надо вставлять его?!

Его вставлять в HTML-низ.
В самом скрипте нужно лишь заменить это:

makeSubforum('forum_f8', 'forum_f2')

8 - заменяете на id раздела,к которому "приделан" подфорум.
2 - заменяете на id самого подфорума.

0

3

Всё сделал,работает!СПАСИБО!
Но у него есть такая проблема:После удаления хотябы одного поста из подфорума,на главной странице перестаёт отображаться последнее сообщение,а счётчик постов считает правильно!
Можно ли эту проблему как-то устранить?!

0

4

BenDeen написал(а):

Можно ли эту проблему как-то устранить?!

Это нужно к скриптеру (Duka) обращаться,возможно он поможет.

0

5

Ещё даже если перенести тему из или в Подфорум,то тоже исчезает с главной страници отображение последнего поста!

0

6

Ирина написал(а):

Это нужно к скриптеру (Duka) обращаться,возможно он поможет.

Что-то автор скрипта никак не реагирует!!!Может у кого-нибудь есть альтернативный вариант?!Или может кто-нибудь имеет связь с автором скрипта?!Очень нужно решить эту проблему!!!Потому-что на моём форуме http://bendeen.spybb.ru без подфорумов получится каша-малаша!Заранее благодарю!!!

0

7

Незнаю, дополнение писала Zebra, я не знаю что и как там у этого скрипта. Спросите у Зебры

0

8

Создание подфорумов с помощью скриптов там столько написано,а можно всё обьеденить,одним скриптом веерх другим вниз,чтоб только подставлять адреса и Id?Уже два дня бьюсь ничего не выходит,запутался вконец
http://uaget.spybb.ru/

0

9

abrakadabra
Все,что касается редактирования скриптов - это к Duka,тут я Вам к сожалению ничем не помогу.

0

10

abrakadabra, объединить можно только это муторнее в разы, чем взять и сделать подфорумы из существующих скриптов.

0

11

Вставляю скрипт   <script language="JavaScript">
str=document.URL
if(str.substring(str.lastIndexOf('/')+1)=="" || str.substring(str.lastIndexOf('/')+1)=="index.php")
   document.write("<style>#forum_fxx{display:none}</style>")
</script>

Всё равно форум виден на главной

0

12

abrakadabra написал(а):

Всё равно форум виден на главной

Вот тут:
#forum_fxx
Вместо хх - поставили id раздела?

0

13

Ирина написал(а):

Вот тут:#forum_fxxВместо хх - поставили id раздела?

Поставил конечно

0

14

Гляньте как выглядит предпоследнее,http://uaget.spybb.ru/

0

15

abrakadabra
Может Вам помочь составить это все? Я думаю так будет проще,чем искать ошибки в коде.

0

16

Ирина
Был бы безмерно благодарен,я бы дал вам права модератора,чтоб вы смогли разобраться, помогите с этими скриптами,пожалуйста.

0

17

abrakadabra
Нужны права админа.Сейчас зарегистрируюсь.А пока напишите в ЛС что и как.

0

18

Ок спасибо

0

19

abrakadabra
Отправила Вам ЛС.Пока Вы не ответите,то я ничего не смогу сделать.

0

20

Я вам отослал

0


Вы здесь » Техническая поддержка SpyBB » Архив » Не работает скрипт Подфорумов!